Problems with the full version of AspMap - shape file layer not shown

10/19/2012 5:48:02 AM
Total Posts 18

Problems with the full version of AspMap - shape file layer not shown

I'm having a problem with the full version of AspMap. At first I have installed AspMap Demo Version on a test computer (Win 7 Pro - 64 bit). I created sample pages and tested shape layers, wms layers and shape data layers (load points / polygons from database). Everything was fine, so we have bought the „AspMap Developer Edition".

Now I've installed the licensed version on my real developer machine (Win 7 Pro - 64 bit also). I'm using IIS 7.5 (not Cassini - like on the test computer). My application pool is configured for "Enable 32-bit Applications". I've added the 32-bit versions of "AspMapNET.dll" and "AspMapUtil.dll" to the BIN-directory of my Asp.Net web site. I've also added the appropriate httpHandler configuration in web.config (following your documentation). Then I've transferred my sample pages from the test computer.

But now I'm having some problems loading the map in the application. The shape file layers and shape data layers are not shown correctly after page load. The WMS layer is shown, but the shape file layers are not visible. In the status bar of IE is written "(Noch 3 Elemente) Bild http://localhost/Projektname/MapImageHandler.axd?image=temp_5500....png wird geladen" (in English "(3 elements to load) image http://localhost/Projektname/MapImageHandler.axd?image=temp_5500....png will be load"). The 3 elements are:  shape layer in map, shape layer in map locator and the legend.

When I then click to any button on the toolbar, which initiates a postback without the Ajax UpdatePanel, for example the button to create an image file of the map, the shape files will be shown directly and correct after the refresh. Even when I remove the update panels from the page, the behavior (i.e. the shape file layers are not visible after the initial page load) remains the same.

What can I do to get the behavior of the Demo Version (i.e. to see all layers) back? Could you help me please?

 

Anke

10/19/2012 2:36:21 PM
MVP
Total Posts 323

Re: Problems with the full version of AspMap - shape file layer not shown

If you are a customer and require expedited support, please submit a support ticket at http://vdstech.com/ccp.aspx and attach a runnable version of your project with the data (without the DLLs).

10/23/2012 6:04:17 AM
Total Posts 18

Re: Problems with the full version of AspMap - shape file layer not shown

My project is very big and inherits some 3rds Party dll's etc. It is not so easy to give you a runnable version :-(

 

Perhaps you can help me without it? If I use cassini on my developer machine the shape layers will load correctly. The error only occurs on IIS 7.5 on my Win 7 64 bit machine. I have tested my web application with .Net Framework 3.5 and .Net Framework 4.0, with Application pool in version "2.0.50727" and version "4.0.30319" combined with classic mode and integrated mode. I use AspMap Version 32 bit and have activate "Enable 32-bit Applications" for tested app pools.

That are your regards for IIS configuration? I found only an sample in the forum and the documentation to configure the web.config: http://vdstech.com/Forums/Thread.aspx?pageid=34&mid=13&ItemID=1&thread=2

But how I must configurate the IIS exactly?

 

In the case, that the shape file can not be load, I have tryed to call the picture url directly (which is shown in IE 8 status bar), by input the address in browser (f.e. http://localhost/Projektname/MapImageHandler.axd?image=temp_9527b3ca-b4bc-4e92-b333b5e67ce317a45.png), I get only a empty image with text "Image not found [E02]".

If I go to web page and say "right mouse click" --> "refresh", so the shape file will shown sometimes correctly (not allways). If I call than the picture url directly, I get the correct image.

I think it is a problem with your MapImageHandler. That says Error "E02" by loading image?

 

Anke

12/11/2012 9:34:10 AM
Total Posts 18

Re: Problems with the full version of AspMap - shape file layer not shown

I now use "ImageTempDirectory" and have removed Handler in web.config. Now all is fine. Also I set the "ImageTimeout" of map, mapLocator and legend to 5, so that generated image will be deleted automatically after 5 minutes ;-)

12/11/2012 10:16:01 AM
MVP
Total Posts 323

Re: Problems with the full version of AspMap - shape file layer not shown

The E02 error means that the map image was not found in the ASP.NET's Cache object or the image was removed from the Cache by ASP.NET before the MapImageHandler had a chance to output it to the web browser.

8/22/2017 2:05:52 AM
Total Posts 11

Re: Problems with the full version of AspMap - shape file layer not shown

How to set aspmap script in vb.net in about TempDirectory for Images..may MVP gave a sample? Thank You